Commit 0987b8ea authored by Yan's avatar Yan

Fixes to setup.py and __init__

* made compatible with rawprasslib 0.0.6 and rawautoparams 0.0.3
* simplified version number management
* more version info in "about"
* setup.py is more descriptive
parent af22bd3f
"""Prasopes init"""
from . import config
from . import datatools
from . import docks
from . import drltools
from . import filetools
from . import graphtools
from . import imagetools
from . import predictmz
from . import tangoicons
from . import zcetools
from . import zcetools_help
__version__ = "0.0.15"
__all__ = ['config', 'datatools', 'docks', 'drltools', 'filetools',
'graphtools', 'imagetools', 'predictmz', 'tangoicons', 'zcetools',
'zcetools_help']
......@@ -5,13 +5,14 @@ from PyQt5 import QtWidgets
from PyQt5 import QtGui
from PyQt5 import QtPrintSupport
from rawprasslib import load_raw
from rawprasslib import rawprasslib
from prasopes.predictmz import predict as getmzpattern
try:
from rawautoparams import load_params
import rawautoparams
autoparams = True
except ImportError:
autoparams = False
import rawprasslib
import numpy as np
import prasopes.config as cf
import prasopes.datatools as dt
......@@ -210,10 +211,16 @@ def key_pressed(event, augCanvas, config):
def about(parent):
"""constructs window with "about" info"""
rawparver = rawautoparams.__version__ if autoparams else\
"library not found"
QtWidgets.QMessageBox.information(
parent, "About Prasopes",
"Prasopes Finnigan raw file viewer\n\n"
"Version: 0.0.14 (alpha)")
"Version: {} (alpha)\n\n"
"Rawprasslib version: {}\n"
"Rawautoparams version: {}".format(
prasopes.__version__, rawprasslib.__version__, rawparver))
def main():
......
from setuptools import setup
from prasopes import __version__ #as version
with open("README.md", "r") as fh:
long_description = fh.read()
setup(
name="prasopes",
version="0.0.14",
version=__version__,
author="Jan Zelenka",
author_email="3yanyanyan@gmail.com",
description="Thermo/Finnigan .raw file viewer based on rawprasslib",
......@@ -13,22 +16,30 @@ setup(
url="https://gitlab.science.ru.nl/jzelenka/prasopes",
packages=['prasopes'],
classifiers=[
"Programming Language :: Python",
"Programming Language :: Python :: 3",
"Programming Language :: Python :: 3.5",
"Programming Language :: Python :: 3.6",
"Programming Language :: Python :: 3.7",
"Operating System :: OS Independent",
"Development Status :: 3-Alpha",
"Operating System :: Microsoft :: Windows",
"Operating System :: Unix",
"Operating System :: MacOS",
"Development Status :: 3 - Alpha",
"Intended Audience :: Science/Research",
"Topic :: Scientific/Engineering :: Chemistry",
],
install_requires=['numpy',
#On Linux distro-packaged Qt/PyQt is preffered
python_requires='>=3.5',
install_requires=['numpy>=1.13.0',
# On Linux distro-packaged Qt/PyQt is preffered
'PyQt5;platform_system=="Windows"',
'PyQt5-sip;platform_system=="Windows"',
'PyQt5;platform_system=="Darwin"',
'PyQt5-sip;platform_system=="Darwin"',
'matplotlib>=3.0.0',
'rawprasslib>=0.0.4'],
'rawprasslib>=0.0.6'],
extras_require={
'raw parameters readout': ['rawautoparams>=0.0.2']},
'raw parameters readout': ['rawautoparams>=0.0.3']},
entry_points={
'console_scripts': [
'prasopes = prasopes.__main__:main'
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment