Commit 2ca466aa authored by Sébastiaan Versteeg's avatar Sébastiaan Versteeg Committed by Gijs Hendriksen

Update react native

parent c2fc902a
{
"presets": ["react-native", "module:react-native-dotenv"],
"plugins": ["@babel/plugin-proposal-object-rest-spread", "@babel/transform-regenerator"]
}
\ No newline at end of file
"presets": [
"module:react-native-dotenv",
"module:metro-react-native-babel-preset"
],
"plugins": [
"@babel/plugin-proposal-object-rest-spread",
"@babel/plugin-proposal-optional-chaining",
"@babel/plugin-transform-flow-strip-types",
"@babel/plugin-proposal-class-properties",
"@babel/plugin-transform-regenerator",
"@babel/plugin-transform-runtime"
]
}
......@@ -12,7 +12,8 @@
android:icon="@mipmap/ic_launcher"
android:roundIcon="@mipmap/ic_launcher_round"
android:theme="@style/AppTheme"
android:launchMode="singleTop">
android:launchMode="singleTop"
android:usesCleartextTraffic="true">
<activity
android:name=".MainActivity"
android:label="@string/app_name"
......
......@@ -3,6 +3,7 @@
buildscript {
repositories {
google()
mavenCentral()
jcenter()
}
dependencies {
......@@ -16,20 +17,21 @@ buildscript {
allprojects {
repositories {
google()
mavenLocal()
jcenter()
maven {
// All of React Native (JS, Obj-C sources, Android binaries) is installed from npm
url "$rootDir/../node_modules/react-native/android"
}
google()
mavenCentral()
mavenLocal()
jcenter()
}
}
ext {
buildToolsVersion = "27.0.3"
buildToolsVersion = "28.0.3"
minSdkVersion = 16
compileSdkVersion = 27
targetSdkVersion = 27
supportLibVersion = "27.1.1"
compileSdkVersion = 28
targetSdkVersion = 28
supportLibVersion = "28.0.0"
}
......@@ -49,17 +49,19 @@
"dependencies": {
"i18next": "^11.4.0",
"i18next-react-native-language-detector": "^1.0.2",
"moment": "^2.22.2",
"prop-types": "^15.6.2",
"react": "16.4.1",
"metro-react-native-babel-preset": "^0.52.0",
"moment": "^2.24.0",
"prop-types": "^15.7.2",
"react": "^16.8.2",
"react-i18next": "^7.9.0",
"react-native": "0.56.0",
"react-native": "0.58.5",
"react-native-cli": "^2.0.1",
"react-native-dotenv": "^0.2.0",
"react-native-drawer": "^2.3.0",
"react-native-firebase": "5.0.0-rc0",
"react-native-linear-gradient": "^2.4.0",
"react-native-locale-detector": "^1.0.1",
"react-native-render-html": "^3.10.0",
"react-native-render-html": "^4.1.1",
"react-native-sentry": "^0.39.0",
"react-native-share": "^1.1.3",
"react-native-snackbar": "^0.4.7",
......@@ -70,21 +72,27 @@
"redux-saga": "^0.16.0"
},
"devDependencies": {
"@babel/plugin-transform-runtime": "^7.0.0-beta.56",
"@babel/plugin-proposal-class-properties": "^7.3.3",
"@babel/plugin-proposal-optional-chaining": "^7.2.0",
"@babel/plugin-transform-flow-strip-types": "^7.2.3",
"@babel/plugin-transform-runtime": "^7.2.0",
"@babel/preset-env": "^7.3.1",
"@babel/preset-react": "^7.0.0",
"babel-core": "7.0.0-bridge.0",
"babel-eslint": "^9.0.0-beta.3",
"babel-jest": "^23.4.2",
"babel-preset-react-native": "5.0.2",
"babel-eslint": "^10.0.1",
"babel-jest": "^24.1.0",
"babel-preset-react-native": "^4.0.1",
"eslint": "^5.2.0",
"eslint-config-airbnb": "^17.0.0",
"eslint-plugin-import": "^2.13.0",
"eslint-plugin-jsx-a11y": "^6.1.1",
"eslint-plugin-react": "^7.10.0",
"eslint-plugin-react-native": "^3.2.1",
"eslint-config-airbnb": "^17.1.0",
"eslint-plugin-import": "^2.16.0",
"eslint-plugin-jsx-a11y": "^6.2.1",
"eslint-plugin-react": "^7.12.4",
"eslint-plugin-react-native": "^3.6.0",
"fsevents": "^1.2.7",
"i18next-scanner": "^2.6.3",
"jest": "^23.4.2",
"react-native-git-upgrade": "^0.2.7",
"react-test-renderer": "^16.3.0-alpha.1",
"react-test-renderer": "^16.8.2",
"redux-mock-store": "^1.5.1",
"redux-saga-test-plan": "^3.2.0"
}
......
This diff is collapsed.
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment