Commit 3c5c6b32 authored by Wietse Kuipers's avatar Wietse Kuipers
Browse files

Merge branch 'react-icons' into 'master'

Added react-native-vector-icons

See merge request !12
parents 397b0930 47c2f987
<?xml version="1.0" encoding="UTF-8"?> <?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd"> <!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
<plist version="1.0"> <plist version="1.0">
<dict> <dict>
<key>CFBundleDevelopmentRegion</key> <key>CFBundleDevelopmentRegion</key>
<string>en</string> <string>en</string>
<key>CFBundleDisplayName</key> <key>CFBundleDisplayName</key>
...@@ -39,9 +39,8 @@ ...@@ -39,9 +39,8 @@
<key>UIViewControllerBasedStatusBarAppearance</key> <key>UIViewControllerBasedStatusBarAppearance</key>
<false/> <false/>
<key>NSLocationWhenInUseUsageDescription</key> <key>NSLocationWhenInUseUsageDescription</key>
<string></string> <string/>
<key>NSAppTransportSecurity</key> <key>NSAppTransportSecurity</key>
<!--See http://ste.vn/2015/06/10/configuring-app-transport-security-ios-9-osx-10-11/ -->
<dict> <dict>
<key>NSExceptionDomains</key> <key>NSExceptionDomains</key>
<dict> <dict>
...@@ -52,5 +51,18 @@ ...@@ -52,5 +51,18 @@
</dict> </dict>
</dict> </dict>
</dict> </dict>
</dict> <key>UIAppFonts</key>
<array>
<string>Entypo.ttf</string>
<string>EvilIcons.ttf</string>
<string>FontAwesome.ttf</string>
<string>Foundation.ttf</string>
<string>Ionicons.ttf</string>
<string>MaterialCommunityIcons.ttf</string>
<string>MaterialIcons.ttf</string>
<string>Octicons.ttf</string>
<string>SimpleLineIcons.ttf</string>
<string>Zocial.ttf</string>
</array>
</dict>
</plist> </plist>
\ No newline at end of file
...@@ -37,7 +37,7 @@ ...@@ -37,7 +37,7 @@
- (void)testRendersWelcomeScreen - (void)testRendersWelcomeScreen
{ {
UIViewController *vc = [[[[UIApplication sharedApplication] delegate] window] rootViewController]; UIViewController *vc = [[[RCTSharedApplication() delegate] window] rootViewController];
NSDate *date = [NSDate dateWithTimeIntervalSinceNow:TIMEOUT_SECONDS]; NSDate *date = [NSDate dateWithTimeIntervalSinceNow:TIMEOUT_SECONDS];
BOOL foundElement = NO; BOOL foundElement = NO;
......
const path = require('path');
module.exports = { module.exports = {
entry: './index.web.js', entry: './index.web.js',
output: { output: {
...@@ -15,6 +17,11 @@ module.exports = { ...@@ -15,6 +17,11 @@ module.exports = {
include: /node_modules\/react-native-/, include: /node_modules\/react-native-/,
loader: 'babel-loader', loader: 'babel-loader',
}, },
{
test: /\.ttf$/,
loader: 'url-loader',
include: path.resolve(__dirname, 'node_modules/react-native-vector-icons'),
},
], ],
}, },
resolve: { resolve: {
......
...@@ -54,7 +54,7 @@ acorn@^4.0.3, acorn@^4.0.4: ...@@ -54,7 +54,7 @@ acorn@^4.0.3, acorn@^4.0.4:
version "4.0.11" version "4.0.11"
resolved "https://registry.yarnpkg.com/acorn/-/acorn-4.0.11.tgz#edcda3bd937e7556410d42ed5860f67399c794c0" resolved "https://registry.yarnpkg.com/acorn/-/acorn-4.0.11.tgz#edcda3bd937e7556410d42ed5860f67399c794c0"
acorn@^5.0.1: acorn@^5.0.0, acorn@^5.0.1:
version "5.0.3" version "5.0.3"
resolved "https://registry.yarnpkg.com/acorn/-/acorn-5.0.3.tgz#c460df08491463f028ccb82eab3730bf01087b3d" resolved "https://registry.yarnpkg.com/acorn/-/acorn-5.0.3.tgz#c460df08491463f028ccb82eab3730bf01087b3d"
...@@ -63,8 +63,8 @@ ajv-keywords@^1.0.0, ajv-keywords@^1.1.1: ...@@ -63,8 +63,8 @@ ajv-keywords@^1.0.0, ajv-keywords@^1.1.1:
resolved "https://registry.yarnpkg.com/ajv-keywords/-/ajv-keywords-1.5.1.tgz#314dd0a4b3368fad3dfcdc54ede6171b886daf3c" resolved "https://registry.yarnpkg.com/ajv-keywords/-/ajv-keywords-1.5.1.tgz#314dd0a4b3368fad3dfcdc54ede6171b886daf3c"
ajv@^4.7.0, ajv@^4.9.1: ajv@^4.7.0, ajv@^4.9.1:
version "4.11.6" version "4.11.8"
resolved "https://registry.yarnpkg.com/ajv/-/ajv-4.11.6.tgz#947e93049790942b2a2d60a8289b28924d39f987" resolved "https://registry.yarnpkg.com/ajv/-/ajv-4.11.8.tgz#82ffb02b29e662ae53bdc20af15947706739c536"
dependencies: dependencies:
co "^4.6.0" co "^4.6.0"
json-stable-stringify "^1.0.1" json-stable-stringify "^1.0.1"
...@@ -128,11 +128,11 @@ aproba@^1.0.3: ...@@ -128,11 +128,11 @@ aproba@^1.0.3:
resolved "https://registry.yarnpkg.com/aproba/-/aproba-1.1.1.tgz#95d3600f07710aa0e9298c726ad5ecf2eacbabab" resolved "https://registry.yarnpkg.com/aproba/-/aproba-1.1.1.tgz#95d3600f07710aa0e9298c726ad5ecf2eacbabab"
are-we-there-yet@~1.1.2: are-we-there-yet@~1.1.2:
version "1.1.2" version "1.1.4"
resolved "https://registry.yarnpkg.com/are-we-there-yet/-/are-we-there-yet-1.1.2.tgz#80e470e95a084794fe1899262c5667c6e88de1b3" resolved "https://registry.yarnpkg.com/are-we-there-yet/-/are-we-there-yet-1.1.4.tgz#bb5dca382bb94f05e15194373d16fd3ba1ca110d"
dependencies: dependencies:
delegates "^1.0.0" delegates "^1.0.0"
readable-stream "^2.0.0 || ^1.1.13" readable-stream "^2.0.6"
argparse@^1.0.7: argparse@^1.0.7:
version "1.0.9" version "1.0.9"
...@@ -147,8 +147,8 @@ arr-diff@^2.0.0: ...@@ -147,8 +147,8 @@ arr-diff@^2.0.0:
arr-flatten "^1.0.1" arr-flatten "^1.0.1"
arr-flatten@^1.0.1: arr-flatten@^1.0.1:
version "1.0.1" version "1.0.3"
resolved "https://registry.yarnpkg.com/arr-flatten/-/arr-flatten-1.0.1.tgz#e5ffe54d45e19f32f216e91eb99c8ce892bb604b" resolved "https://registry.yarnpkg.com/arr-flatten/-/arr-flatten-1.0.3.tgz#a274ed85ac08849b6bd7847c4580745dc51adfb1"
array-differ@^1.0.0: array-differ@^1.0.0:
version "1.0.0" version "1.0.0"
...@@ -237,7 +237,7 @@ async-each@^1.0.0: ...@@ -237,7 +237,7 @@ async-each@^1.0.0:
version "1.0.1" version "1.0.1"
resolved "https://registry.yarnpkg.com/async-each/-/async-each-1.0.1.tgz#19d386a1d9edc6e7c1c85d388aedbcc56d33602d" resolved "https://registry.yarnpkg.com/async-each/-/async-each-1.0.1.tgz#19d386a1d9edc6e7c1c85d388aedbcc56d33602d"
async@0.2.x, async@~0.2.9: async@0.2.x, async@~0.2.6, async@~0.2.9:
version "0.2.10" version "0.2.10"
resolved "https://registry.yarnpkg.com/async/-/async-0.2.10.tgz#b6bbe0b0674b9d719708ca38de8c237cb526c3d1" resolved "https://registry.yarnpkg.com/async/-/async-0.2.10.tgz#b6bbe0b0674b9d719708ca38de8c237cb526c3d1"
...@@ -246,8 +246,8 @@ async@^1.4.0: ...@@ -246,8 +246,8 @@ async@^1.4.0:
resolved "https://registry.yarnpkg.com/async/-/async-1.5.2.tgz#ec6a61ae56480c0c3cb241c95618e20892f9672a" resolved "https://registry.yarnpkg.com/async/-/async-1.5.2.tgz#ec6a61ae56480c0c3cb241c95618e20892f9672a"
async@^2.0.1, async@^2.1.2, async@^2.1.4: async@^2.0.1, async@^2.1.2, async@^2.1.4:
version "2.3.0" version "2.4.0"
resolved "https://registry.yarnpkg.com/async/-/async-2.3.0.tgz#1013d1051047dd320fe24e494d5c66ecaf6147d9" resolved "https://registry.yarnpkg.com/async/-/async-2.4.0.tgz#4990200f18ea5b837c2cc4f8c031a6985c385611"
dependencies: dependencies:
lodash "^4.14.0" lodash "^4.14.0"
...@@ -296,13 +296,13 @@ babel-core@^6.0.0, babel-core@^6.18.0, babel-core@^6.21.0, babel-core@^6.24.1, b ...@@ -296,13 +296,13 @@ babel-core@^6.0.0, babel-core@^6.18.0, babel-core@^6.21.0, babel-core@^6.24.1, b
source-map "^0.5.0" source-map "^0.5.0"
babel-eslint@^7.1.1: babel-eslint@^7.1.1:
version "7.2.2" version "7.2.3"
resolved "https://registry.yarnpkg.com/babel-eslint/-/babel-eslint-7.2.2.tgz#0da2cbe6554fd0fb069f19674f2db2f9c59270ff" resolved "https://registry.yarnpkg.com/babel-eslint/-/babel-eslint-7.2.3.tgz#b2fe2d80126470f5c19442dc757253a897710827"
dependencies: dependencies:
babel-code-frame "^6.22.0" babel-code-frame "^6.22.0"
babel-traverse "^6.23.1" babel-traverse "^6.23.1"
babel-types "^6.23.0" babel-types "^6.23.0"
babylon "^6.16.1" babylon "^6.17.0"
babel-generator@^6.18.0, babel-generator@^6.21.0, babel-generator@^6.24.1: babel-generator@^6.18.0, babel-generator@^6.21.0, babel-generator@^6.24.1:
version "6.24.1" version "6.24.1"
...@@ -479,12 +479,12 @@ babel-plugin-istanbul@^3.0.0: ...@@ -479,12 +479,12 @@ babel-plugin-istanbul@^3.0.0:
test-exclude "^3.3.0" test-exclude "^3.3.0"
babel-plugin-istanbul@^4.0.0: babel-plugin-istanbul@^4.0.0:
version "4.1.1" version "4.1.3"
resolved "https://registry.yarnpkg.com/babel-plugin-istanbul/-/babel-plugin-istanbul-4.1.1.tgz#c12de0fc6fe42adfb16be56f1ad11e4a9782eca9" resolved "https://registry.yarnpkg.com/babel-plugin-istanbul/-/babel-plugin-istanbul-4.1.3.tgz#6ee6280410dcf59c7747518c3dfd98680958f102"
dependencies: dependencies:
find-up "^2.1.0" find-up "^2.1.0"
istanbul-lib-instrument "^1.6.2" istanbul-lib-instrument "^1.7.1"
test-exclude "^4.0.3" test-exclude "^4.1.0"
babel-plugin-jest-hoist@^18.0.0: babel-plugin-jest-hoist@^18.0.0:
version "18.0.0" version "18.0.0"
...@@ -822,8 +822,8 @@ babel-preset-fbjs@^1.0.0: ...@@ -822,8 +822,8 @@ babel-preset-fbjs@^1.0.0:
object-assign "^4.0.1" object-assign "^4.0.1"
babel-preset-fbjs@^2.1.0: babel-preset-fbjs@^2.1.0:
version "2.1.0" version "2.1.2"
resolved "https://registry.yarnpkg.com/babel-preset-fbjs/-/babel-preset-fbjs-2.1.0.tgz#1a8d4cacbac7c5a9194ce3b8475ffab33ed524fb" resolved "https://registry.yarnpkg.com/babel-preset-fbjs/-/babel-preset-fbjs-2.1.2.tgz#f52b2df56b1da883ffb7798b3b3be42c4c647a77"
dependencies: dependencies:
babel-plugin-check-es2015-constants "^6.8.0" babel-plugin-check-es2015-constants "^6.8.0"
babel-plugin-syntax-class-properties "^6.8.0" babel-plugin-syntax-class-properties "^6.8.0"
...@@ -962,9 +962,9 @@ babel-types@^6.18.0, babel-types@^6.19.0, babel-types@^6.21.0, babel-types@^6.23 ...@@ -962,9 +962,9 @@ babel-types@^6.18.0, babel-types@^6.19.0, babel-types@^6.21.0, babel-types@^6.23
lodash "^4.2.0" lodash "^4.2.0"
to-fast-properties "^1.0.1" to-fast-properties "^1.0.1"
babylon@^6.11.0, babylon@^6.13.0, babylon@^6.14.1, babylon@^6.15.0, babylon@^6.16.1: babylon@^6.11.0, babylon@^6.13.0, babylon@^6.15.0, babylon@^6.16.1, babylon@^6.17.0:
version "6.16.1" version "6.17.0"
resolved "https://registry.yarnpkg.com/babylon/-/babylon-6.16.1.tgz#30c5a22f481978a9e7f8cdfdf496b11d94b404d3" resolved "https://registry.yarnpkg.com/babylon/-/babylon-6.17.0.tgz#37da948878488b9c4e3c4038893fa3314b3fc932"
balanced-match@^0.4.1: balanced-match@^0.4.1:
version "0.4.2" version "0.4.2"
...@@ -974,6 +974,10 @@ base64-js@0.0.8: ...@@ -974,6 +974,10 @@ base64-js@0.0.8:
version "0.0.8" version "0.0.8"
resolved "https://registry.yarnpkg.com/base64-js/-/base64-js-0.0.8.tgz#1101e9544f4a76b1bc3b26d452ca96d7a35e7978" resolved "https://registry.yarnpkg.com/base64-js/-/base64-js-0.0.8.tgz#1101e9544f4a76b1bc3b26d452ca96d7a35e7978"
base64-js@1.1.2:
version "1.1.2"
resolved "https://registry.yarnpkg.com/base64-js/-/base64-js-1.1.2.tgz#d6400cac1c4c660976d90d07a04351d89395f5e8"
base64-js@^1.0.2, base64-js@^1.1.2: base64-js@^1.0.2, base64-js@^1.1.2:
version "1.2.0" version "1.2.0"
resolved "https://registry.yarnpkg.com/base64-js/-/base64-js-1.2.0.tgz#a39992d723584811982be5e290bb6a53d86700f1" resolved "https://registry.yarnpkg.com/base64-js/-/base64-js-1.2.0.tgz#a39992d723584811982be5e290bb6a53d86700f1"
...@@ -1004,6 +1008,10 @@ beeper@^1.0.0: ...@@ -1004,6 +1008,10 @@ beeper@^1.0.0:
version "1.1.1" version "1.1.1"
resolved "https://registry.yarnpkg.com/beeper/-/beeper-1.1.1.tgz#e6d5ea8c5dad001304a70b22638447f69cb2f809" resolved "https://registry.yarnpkg.com/beeper/-/beeper-1.1.1.tgz#e6d5ea8c5dad001304a70b22638447f69cb2f809"
big-integer@^1.6.7:
version "1.6.22"
resolved "https://registry.yarnpkg.com/big-integer/-/big-integer-1.6.22.tgz#487c95fce886022ea48ff5f19e388932df46dd2e"
big.js@^3.1.3: big.js@^3.1.3:
version "3.1.3" version "3.1.3"
resolved "https://registry.yarnpkg.com/big.js/-/big.js-3.1.3.tgz#4cada2193652eb3ca9ec8e55c9015669c9806978" resolved "https://registry.yarnpkg.com/big.js/-/big.js-3.1.3.tgz#4cada2193652eb3ca9ec8e55c9015669c9806978"
...@@ -1047,17 +1055,19 @@ bowser@^1.6.0: ...@@ -1047,17 +1055,19 @@ bowser@^1.6.0:
version "1.6.1" version "1.6.1"
resolved "https://registry.yarnpkg.com/bowser/-/bowser-1.6.1.tgz#9157e9498f456e937173a2918f3b2161e5353eb3" resolved "https://registry.yarnpkg.com/bowser/-/bowser-1.6.1.tgz#9157e9498f456e937173a2918f3b2161e5353eb3"
bplist-creator@0.0.4: bplist-creator@0.0.7:
version "0.0.4" version "0.0.7"
resolved "https://registry.yarnpkg.com/bplist-creator/-/bplist-creator-0.0.4.tgz#4ac0496782e127a85c1d2026a4f5eb22a7aff991" resolved "https://registry.yarnpkg.com/bplist-creator/-/bplist-creator-0.0.7.tgz#37df1536092824b87c42f957b01344117372ae45"
dependencies: dependencies:
stream-buffers "~0.2.3" stream-buffers "~2.2.0"
bplist-parser@0.0.6: bplist-parser@0.1.1:
version "0.0.6" version "0.1.1"
resolved "https://registry.yarnpkg.com/bplist-parser/-/bplist-parser-0.0.6.tgz#38da3471817df9d44ab3892e27707bbbd75a11b9" resolved "https://registry.yarnpkg.com/bplist-parser/-/bplist-parser-0.1.1.tgz#d60d5dcc20cba6dc7e1f299b35d3e1f95dafbae6"
dependencies:
big-integer "^1.6.7"
brace-expansion@^1.0.0: brace-expansion@^1.1.7:
version "1.1.7" version "1.1.7"
resolved "https://registry.yarnpkg.com/brace-expansion/-/brace-expansion-1.1.7.tgz#3effc3c50e000531fb720eaff80f0ae8ef23cf59" resolved "https://registry.yarnpkg.com/brace-expansion/-/brace-expansion-1.1.7.tgz#3effc3c50e000531fb720eaff80f0ae8ef23cf59"
dependencies: dependencies:
...@@ -1133,18 +1143,12 @@ browserify-zlib@^0.1.4: ...@@ -1133,18 +1143,12 @@ browserify-zlib@^0.1.4:
dependencies: dependencies:
pako "~0.2.0" pako "~0.2.0"
bser@1.0.2: bser@1.0.2, bser@^1.0.2:
version "1.0.2" version "1.0.2"
resolved "https://registry.yarnpkg.com/bser/-/bser-1.0.2.tgz#381116970b2a6deea5646dd15dd7278444b56169" resolved "https://registry.yarnpkg.com/bser/-/bser-1.0.2.tgz#381116970b2a6deea5646dd15dd7278444b56169"
dependencies: dependencies:
node-int64 "^0.4.0" node-int64 "^0.4.0"
bser@^1.0.2:
version "1.0.3"
resolved "https://registry.yarnpkg.com/bser/-/bser-1.0.3.tgz#d63da19ee17330a0e260d2a34422b21a89520317"
dependencies:
node-int64 "^0.4.0"
bser@^2.0.0: bser@^2.0.0:
version "2.0.0" version "2.0.0"
resolved "https://registry.yarnpkg.com/bser/-/bser-2.0.0.tgz#9ac78d3ed5d915804fd87acb158bc797147a1719" resolved "https://registry.yarnpkg.com/bser/-/bser-2.0.0.tgz#9ac78d3ed5d915804fd87acb158bc797147a1719"
...@@ -1227,8 +1231,8 @@ chalk@^1.0.0, chalk@^1.1.0, chalk@^1.1.1, chalk@^1.1.3: ...@@ -1227,8 +1231,8 @@ chalk@^1.0.0, chalk@^1.1.0, chalk@^1.1.1, chalk@^1.1.3:
supports-color "^2.0.0" supports-color "^2.0.0"
chokidar@^1.4.3: chokidar@^1.4.3:
version "1.6.1" version "1.7.0"
resolved "https://registry.yarnpkg.com/chokidar/-/chokidar-1.6.1.tgz#2f4447ab5e96e50fb3d789fd90d4c72e0e4c70c2" resolved "https://registry.yarnpkg.com/chokidar/-/chokidar-1.7.0.tgz#798e689778151c8076b4b360e5edd28cda2bb468"
dependencies: dependencies:
anymatch "^1.3.0" anymatch "^1.3.0"
async-each "^1.0.0" async-each "^1.0.0"
...@@ -1490,19 +1494,13 @@ create-hmac@^1.1.0, create-hmac@^1.1.2: ...@@ -1490,19 +1494,13 @@ create-hmac@^1.1.0, create-hmac@^1.1.2:
inherits "^2.0.1" inherits "^2.0.1"
create-react-class@^15.5.1: create-react-class@^15.5.1:
version "15.5.2" version "15.5.3"
resolved "https://registry.yarnpkg.com/create-react-class/-/create-react-class-15.5.2.tgz#6a8758348df660b88326a0e764d569f274aad681" resolved "https://registry.yarnpkg.com/create-react-class/-/create-react-class-15.5.3.tgz#fb0f7cae79339e9a179e194ef466efa3923820fe"
dependencies: dependencies:
fbjs "^0.8.9" fbjs "^0.8.9"
loose-envify "^1.3.1"
object-assign "^4.1.1" object-assign "^4.1.1"
cross-env@^3.1.4:
version "3.2.4"
resolved "https://registry.yarnpkg.com/cross-env/-/cross-env-3.2.4.tgz#9e0585f277864ed421ce756f81a980ff0d698aba"
dependencies:
cross-spawn "^5.1.0"
is-windows "^1.0.0"
cross-spawn@^3.0.1: cross-spawn@^3.0.1:
version "3.0.1" version "3.0.1"
resolved "https://registry.yarnpkg.com/cross-spawn/-/cross-spawn-3.0.1.tgz#1256037ecb9f0c5f79e3d6ef135e30770184b982" resolved "https://registry.yarnpkg.com/cross-spawn/-/cross-spawn-3.0.1.tgz#1256037ecb9f0c5f79e3d6ef135e30770184b982"
...@@ -1510,14 +1508,6 @@ cross-spawn@^3.0.1: ...@@ -1510,14 +1508,6 @@ cross-spawn@^3.0.1:
lru-cache "^4.0.1" lru-cache "^4.0.1"
which "^1.2.9" which "^1.2.9"
cross-spawn@^5.1.0:
version "5.1.0"
resolved "https://registry.yarnpkg.com/cross-spawn/-/cross-spawn-5.1.0.tgz#e8bd0efee58fcff6f8f94510a0a554bbfa235449"
dependencies:
lru-cache "^4.0.1"
shebang-command "^1.2.0"
which "^1.2.9"
cryptiles@2.x.x: cryptiles@2.x.x:
version "2.0.5" version "2.0.5"
resolved "https://registry.yarnpkg.com/cryptiles/-/cryptiles-2.0.5.tgz#3bdfecdc608147c1c67202fa291e7dca59eaa3b8" resolved "https://registry.yarnpkg.com/cryptiles/-/cryptiles-2.0.5.tgz#3bdfecdc608147c1c67202fa291e7dca59eaa3b8"
...@@ -1592,10 +1582,6 @@ dashdash@^1.12.0: ...@@ -1592,10 +1582,6 @@ dashdash@^1.12.0:
dependencies: dependencies:
assert-plus "^1.0.0" assert-plus "^1.0.0"
date-now@1.0.1:
version "1.0.1"
resolved "https://registry.yarnpkg.com/date-now/-/date-now-1.0.1.tgz#bb7d086438debe4182a485fb3df3fbfb99d6153c"
date-now@^0.1.4: date-now@^0.1.4:
version "0.1.4" version "0.1.4"
resolved "https://registry.yarnpkg.com/date-now/-/date-now-0.1.4.tgz#eaf439fd4d4848ad74e5cc7dbef200672b9e345b" resolved "https://registry.yarnpkg.com/date-now/-/date-now-0.1.4.tgz#eaf439fd4d4848ad74e5cc7dbef200672b9e345b"
...@@ -1605,10 +1591,8 @@ dateformat@^2.0.0: ...@@ -1605,10 +1591,8 @@ dateformat@^2.0.0:
resolved "https://registry.yarnpkg.com/dateformat/-/dateformat-2.0.0.tgz#2743e3abb5c3fc2462e527dca445e04e9f4dee17" resolved "https://registry.yarnpkg.com/dateformat/-/dateformat-2.0.0.tgz#2743e3abb5c3fc2462e527dca445e04e9f4dee17"
debounce@^1.0.0: debounce@^1.0.0:
version "1.0.0" version "1.0.2"
resolved "https://registry.yarnpkg.com/debounce/-/debounce-1.0.0.tgz#0948af513d2e4ce407916f8506a423d3f9cf72d8" resolved "https://registry.yarnpkg.com/debounce/-/debounce-1.0.2.tgz#503cc674d8d7f737099664fb75ddbd36b9626dc6"
dependencies:
date-now "1.0.1"
debug@2.2.0, debug@~2.2.0: debug@2.2.0, debug@~2.2.0:
version "2.2.0" version "2.2.0"
...@@ -1616,12 +1600,18 @@ debug@2.2.0, debug@~2.2.0: ...@@ -1616,12 +1600,18 @@ debug@2.2.0, debug@~2.2.0:
dependencies: dependencies:
ms "0.7.1" ms "0.7.1"
debug@2.6.3, debug@^2.0.0, debug@^2.1.1, debug@^2.2.0: debug@2.6.3:
version "2.6.3" version "2.6.3"
resolved "https://registry.yarnpkg.com/debug/-/debug-2.6.3.tgz#0f7eb8c30965ec08c72accfa0130c8b79984141d" resolved "https://registry.yarnpkg.com/debug/-/debug-2.6.3.tgz#0f7eb8c30965ec08c72accfa0130c8b79984141d"
dependencies: dependencies:
ms "0.7.2" ms "0.7.2"
debug@^2.0.0, debug@^2.1.1, debug@^2.2.0, debug@^2.6.3:
version "2.6.6"
resolved "https://registry.yarnpkg.com/debug/-/debug-2.6.6.tgz#a9fa6fbe9ca43cf1e79f73b75c0189cbb7d6db5a"
dependencies:
ms "0.7.3"
decamelize@^1.0.0, decamelize@^1.1.1: decamelize@^1.0.0, decamelize@^1.1.1:
version "1.2.0" version "1.2.0"
resolved "https://registry.yarnpkg.com/decamelize/-/decamelize-1.2.0.tgz#f6534d15148269b20352e7bee26f501f9a191290" resolved "https://registry.yarnpkg.com/decamelize/-/decamelize-1.2.0.tgz#f6534d15148269b20352e7bee26f501f9a191290"
...@@ -1828,8 +1818,8 @@ es-to-primitive@^1.1.1: ...@@ -1828,8 +1818,8 @@ es-to-primitive@^1.1.1:
is-symbol "^1.0.1" is-symbol "^1.0.1"
es5-ext@^0.10.14, es5-ext@^0.10.9, es5-ext@~0.10.14: es5-ext@^0.10.14, es5-ext@^0.10.9, es5-ext@~0.10.14:
version "0.10.15" version "0.10.16"
resolved "https://registry.yarnpkg.com/es5-ext/-/es5-ext-0.10.15.tgz#c330a5934c1ee21284a7c081a86e5fd937c91ea6" resolved "https://registry.yarnpkg.com/es5-ext/-/es5-ext-0.10.16.tgz#1ef1b04f3d09db6a5d630226d62202f2e425e45a"
dependencies: dependencies:
es6-iterator "2" es6-iterator "2"
es6-symbol "~3.1" es6-symbol "~3.1"
...@@ -1960,8 +1950,8 @@ eslint-plugin-jsx-a11y@^3.0.2: ...@@ -1960,8 +1950,8 @@ eslint-plugin-jsx-a11y@^3.0.2:
object-assign "^4.0.1" object-assign "^4.0.1"
eslint-plugin-react-native@^2.2.1: eslint-plugin-react-native@^2.2.1:
version "2.3.1" version "2.3.2"
resolved "https://registry.yarnpkg.com/eslint-plugin-react-native/-/eslint-plugin-react-native-2.3.1.tgz#9ecd1df4f29c23a9a20c415c8e88466ff3724f0e" resolved "https://registry.yarnpkg.com/eslint-plugin-react-native/-/eslint-plugin-react-native-2.3.2.tgz#e1b2ba2d97fb46b16fe2dbb5bd4d0f47419f2859"
eslint-plugin-react@^6.9.0: eslint-plugin-react@^6.9.0:
version "6.10.3" version "6.10.3"
...@@ -2014,8 +2004,8 @@ eslint@^3.15.0: ...@@ -2014,8 +2004,8 @@ eslint@^3.15.0:
user-home "^2.0.0" user-home "^2.0.0"
espree@^3.4.0: espree@^3.4.0:
version "3.4.1" version "3.4.3"
resolved "https://registry.yarnpkg.com/espree/-/espree-3.4.1.tgz#28a83ab4aaed71ed8fe0f5efe61b76a05c13c4d2" resolved "https://registry.yarnpkg.com/espree/-/espree-3.4.3.tgz#2910b5ccd49ce893c2ffffaab4fd8b3a31b82374"
dependencies: dependencies:
acorn "^5.0.1" acorn "^5.0.1"
acorn-jsx "^3.0.0" acorn-jsx "^3.0.0"
...@@ -2119,8 +2109,8 @@ express-session@~1.11.3: ...@@ -2119,8 +2109,8 @@ express-session@~1.11.3:
utils-merge "1.0.0" utils-merge "1.0.0"
extend@~3.0.0: extend@~3.0.0:
version "3.0.0" version "3.0.1"
resolved "https://registry.yarnpkg.com/extend/-/extend-3.0.0.tgz#5a474353b9f3353ddd8176dfd37b91c83a46f1d4" resolved "https://registry.yarnpkg.com/extend/-/extend-3.0.1.tgz#a755ea7bc1adfcc5a31ce7e762dbaadc5e636444"
extglob@^0.3.1: extglob@^0.3.1:
version "0.3.2" version "0.3.2"
...@@ -2199,8 +2189,8 @@ file-entry-cache@^2.0.0: ...@@ -2199,8 +2189,8 @@ file-entry-cache@^2.0.0:
object-assign "^4.0.1" object-assign "^4.0.1"
filename-regex@^2.0.0: filename-regex@^2.0.0:
version "2.0.0" version "2.0.1"
resolved "https://registry.yarnpkg.com/filename-regex/-/filename-regex-2.0.0.tgz#996e3e80479b98b9897f15a8a58b3d084e926775" resolved "https://registry.yarnpkg.com/filename-regex/-/filename-regex-2.0.1.tgz#c1c4b9bee3e09725ddb106b75c1e301fe2f18b26"
fileset@^2.0.2: fileset@^2.0.2:
version "2.0.3" version "2.0.3"
...@@ -2294,15 +2284,13 @@ fresh@0.3.0: ...@@ -2294,15 +2284,13 @@ fresh@0.3.0:
version "0.3.0" version "0.3.0"
resolved "https://registry.yarnpkg.com/fresh/-/fresh-0.3.0.tgz#651f838e22424e7566de161d8358caa199f83d4f" resolved "https://registry.yarnpkg.com/fresh/-/fresh-0.3.0.tgz#651f838e22424e7566de161d8358caa199f83d4f"
fs-extra@^0.26.2: fs-extra@^1.0.0:
version "0.26.7" version "1.0.0"
resolved "https://registry.yarnpkg.com/fs-extra/-/fs-extra-0.26.7.tgz#9ae1fdd94897798edab76d0918cf42d0c3184fa9" resolved "https://registry.yarnpkg.com/fs-extra/-/fs-extra-1.0.0.tgz#cd3ce5f7e7cb6145883fcae3191e9877f8587950"
dependencies: dependencies:
graceful-fs "^4.1.2" graceful-fs "^4.1.2"
jsonfile "^2.1.0" jsonfile "^2.1.0"
klaw "^1.0.0" klaw "^1.0.0"
path-is-absolute "^1.0.0"
rimraf "^2.2.8"
fs.realpath@^1.0.0: fs.realpath@^1.0.0:
version "1.0.0" version "1.0.0"
...@@ -2346,9 +2334,9 @@ gauge@~1.2.5: ...@@ -2346,9 +2334,9 @@ gauge@~1.2.5:
lodash.padend "^4.1.0" lodash.padend "^4.1.0"
lodash.padstart "^4.1.0" lodash.padstart "^4.1.0"
gauge@~2.7.1: gauge@~2.7.3:
version "2.7.3" version "2.7.4"
resolved "https://registry.yarnpkg.com/gauge/-/gauge-2.7.3.tgz#1c23855f962f17b3ad3d0dc7443f304542edfe09" resolved "https://registry.yarnpkg.com/gauge/-/gauge-2.7.4.tgz#2c03405c7538c39d7eb37b317022e325fb018bf7"
dependencies: dependencies:
aproba "^1.0.3" aproba "^1.0.3"
console-control-strings "^1.0.0" console-control-strings "^1.0.0"
...@@ -2374,8 +2362,8 @@ get-caller-file@^1.0.1: ...@@ -2374,8 +2362,8 @@ get-caller-file@^1.0.1:
resolved "https://registry.yarnpkg.com/get-caller-file/-/get-caller-file-1.0.2.tgz#f702e63127e7e231c160a80c1554acb70d5047e5" resolved "https://registry.yarnpkg.com/get-caller-file/-/get-caller-file-1.0.2.tgz#f702e63127e7e231c160a80c1554acb70d5047e5"
getpass@^0.1.1: getpass@^0.1.1:
version "0.1.6" version "0.1.7"
resolved "https://registry.yarnpkg.com/getpass/-/getpass-0.1.6.tgz#283ffd9fc1256840875311c1b60e8c40187110e6" resolved "https://registry.yarnpkg.com/getpass/-/getpass-0.1.7.tgz#5eff8e3e684d569ae4cb2b1282604e8ba62149fa"
dependencies: dependencies:
assert-plus "^1.0.0" assert-plus "^1.0.0"
...@@ -2392,16 +2380,6 @@ glob-parent@^2.0.0: ...@@ -2392,16 +2380,6 @@ glob-parent@^2.0.0:
dependencies: dependencies:
is-glob "^2.0.0" is-glob "^2.0.0"
glob@^5.0.15:
version "5.0.15"
resolved "https://registry.yarnpkg.com/glob/-/glob-5.0.15.tgz#1bc936b9e02f4a603fcc222ecf7633d30b8b93b1"
dependencies:
inflight "^1.0.4"
inherits "2"
minimatch "2 || 3"
once "^1.3.0"
path-is-absolute "^1.0.0"
glob@^6.0.1: glob@^6.0.1:
version "6.0.4" version "6.0.4"
resolved "https://registry.yarnpkg.com/glob/-/glob-6.0.4.tgz#0f08860f6a155127b2fadd4f9ce24b1aab6e4d22" resolved "https://registry.yarnpkg.com/glob/-/glob-6.0.4.tgz#0f08860f6a155127b2fadd4f9ce24b1aab6e4d22"
...@@ -2412,7 +2390,7 @@ glob@^6.0.1: ...@@ -2412,7 +2390,7 @@ glob@^6.0.1: