Commit c1c8e62f authored by Sébastiaan Versteeg's avatar Sébastiaan Versteeg Committed by Gijs Hendriksen

Fix GitLab pipelines

parent 2ca466aa
image: node:8-alpine
image: mhart/alpine-node:10
variables:
GRADLE_USER_HOME: $CI_PROJECT_DIR/.gradle
......@@ -10,6 +10,7 @@ stages:
eslint:
stage: validate
before_script:
- apk update && apk add git
- yarn install
script:
- yarn lint:ci
......@@ -17,6 +18,7 @@ eslint:
jest:
stage: validate
before_script:
- apk update && apk add git
- yarn install
script:
- yarn jest
......@@ -50,6 +52,7 @@ build android:
- set +o pipefail
- yes | /opt/android-sdk-linux/tools/bin/sdkmanager --licenses
- set -o pipefail
- apk update && apk add git
- yarn install
script:
- echo $SENTRY_PROPS | base64 -d > ./android/sentry.properties
......
......@@ -3623,14 +3623,6 @@ fs.realpath@^1.0.0:
resolved "https://registry.yarnpkg.com/fs.realpath/-/fs.realpath-1.0.0.tgz#1504ad2523158caa40db4a2787cb01411994ea4f"
integrity sha1-FQStJSMVjKpA20onh8sBQRmU6k8=
fsevents@^1.2.3, fsevents@^1.2.7:
version "1.2.7"
resolved "https://registry.yarnpkg.com/fsevents/-/fsevents-1.2.7.tgz#4851b664a3783e52003b3c66eb0eee1074933aa4"
integrity sha512-Pxm6sI2MeBD7RdD12RYsqaP0nMiwx8eZBXCa6z2L+mRHm2DYrOYwihmhjpkdjUHwQhslWQjRpEgNq4XvBmaAuw==
dependencies:
nan "^2.9.2"
node-pre-gyp "^0.10.0"
fsm-iterator@^1.1.0:
version "1.1.0"
resolved "https://registry.yarnpkg.com/fsm-iterator/-/fsm-iterator-1.1.0.tgz#337de45de19eb205788cf02e3a955ec206760dec"
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment